Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: USA Stammtisch Forum - Info's rund um USA und Kanada. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

1

Mittwoch, 20. April 2011, 11:44

PROBLEME MIT DEM FORUM

Promleme mit dem Forum

Leider hat der Umzug NIX gebracht, eher ist es schlimmer
geworden. Ich habe zu Testzwecken mal diverse Boxen im
Portal ausgeblendet, wir hoffen so den Fehler einzugrenzen.

Ich kann noch nicht sagen, wie lange es dauert....

Andree

Es haben sich bereits 30 Gäste bedankt.
  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

2

Mittwoch, 20. April 2011, 15:13

RE: PROBLEME MIT DEM FORUM

Ich brauche Eure Unterstützung:

Bitte berichtet hier von irgendwelchen Fehlern.

Wenn der typische SQL (maximum User blabla) kommt,
braucht Ihr nur SQL Fehler schreiben, dann weis ich schon bescheid.

Schön währe aber zu erfahren WO und WANN der Fehler aufgetreten ist.
Evtl. finden wir ja den Übeltäter.

Andree

PS: Was mich auch mal interessieren würde:
Ich habe ja das Portal entschlankt... Ist das wirklich schneller geworden
oder kommt es nur mir so vor...

Kalle

Cheffe

Beiträge: 6 041

Beruf: Nix

Danksagungen: 2022

  • Nachricht senden

3

Mittwoch, 20. April 2011, 15:55

RE: PROBLEME MIT DEM FORUM

Das Gefühl habe ich auch.
Bei[img] http://www.usa-stammtisch.de/bilder/nummer/31.gif[/img] Stammtischtreffen dabei

Zum Arbeiten zu alt,
zum Sterben zu jung,
zum Reisen topfitt ...

Werbung

unregistriert

Werbung


Beiträge: 1 478

Beruf: ?

Danksagungen: 59

  • Nachricht senden

4

Mittwoch, 20. April 2011, 16:35

SQL Fehler mehrfach heute morgen ca. 7:30 im Forum (versch. Beiträge)
Hauptseite ging.
Bei vielen Stammtischtreffen dabei :rolleyes:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Eric« (20. April 2011, 16:37)


  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

5

Mittwoch, 20. April 2011, 16:37

Zitat

Original von Eric
SQL Fehler mehrfach heute morgen ca. 7:30 im Forum (versch. Beiträge)
Hauptseite ging.


Ok, war vor der Anpassung.
Alle Fehler ab heute 12.00 Uhr bitte

Andree

Kalle

Cheffe

Beiträge: 6 041

Beruf: Nix

Danksagungen: 2022

  • Nachricht senden

6

Mittwoch, 20. April 2011, 16:50

Die Hauptseite geht immer(hoffe ich),hat nichts mit der Datenbank vom Forum zu tun
Bei[img] http://www.usa-stammtisch.de/bilder/nummer/31.gif[/img] Stammtischtreffen dabei

Zum Arbeiten zu alt,
zum Sterben zu jung,
zum Reisen topfitt ...

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

7

Mittwoch, 20. April 2011, 16:52

Kalle für die einen ist die Hauptseite das Portal, für die anderen
das hässliche Menü unter www.usa-stammtisch.de :zwinker:

Also immer schön sagen WO genau (also Portal etc.) der Fehler war.
Aber es zählen nur Fehler seit 12.00 Uhr heute Mittag, denn da
habe ich erst alles fertig gehabt.

Andree

Werbung

unregistriert

Werbung


  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

8

Mittwoch, 20. April 2011, 21:10

Der Kalender ist auch nicht da zur Zeit....

Andree

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

9

Donnerstag, 21. April 2011, 07:48

RE: PROBLEME MIT DEM FORUM

FUCK FUCK FUCK FUCK

Ich bin mit meinem Wissen am Ende....
Ich habe sogar die Änderungsdaten der ganzen Server Daten angesehen.
Seit mehreren Jahren wurde da nix verändert. Warum treten die Probleme
jetzt so gehäuft auf?

Ich mach erst mal Osterurlaub und dann sehen wir weiter....
Scheiße.

Andree

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

10

Donnerstag, 21. April 2011, 08:10

Zitat

Original von VoF Fan
Also bei mir ist es nicht schlimmer geworden, wenn das Problem nicht zu lokalisieren ist, könnten wir dann den $Kurs wiederhaben?


Nein, erstmal nicht

Andree

Beiträge: 345

Danksagungen: 74

  • Nachricht senden

11

Donnerstag, 21. April 2011, 08:22

Hi,

hast Du mal versucht die Azahl der max. "Userconnection" einfach etwas hoch zu setzen?

Entweder geht es hier um die Gesamtanzahl der User die mit der Datenbank verbunden werden können, oder um einen bestimmten User, der mehrere Sessions benutzt. Evt. wäre hier eine Abfrage sinnvoll die den User beim Verlassen des Forums darauf aufmerksam macht, sich abzumelden.

Oder eine Automatische Abmeldung nach... vielleicht 5min Inaktivität.

Könnte ein Lösungsansatz sein.

Grüße

Chris
(IT-Administrator :daumen:)

P.S.
Schau mal hier, vielelicht hilft es!
http://msdn.microsoft.com/de-de/library/ms187882.aspx

Was weitere Ansatzpunkte wären:
- Welche SQL Version benutz Du?
- Welche Harware wird benutzt, wurde hier etwas geändert?
- Evt. Update des SQL Servers! (Vorsicht: User Logins der Datenbank sichern!)
- Über Nachrüstung von Arbeitspeicher nachdenken, da der Wert: "user connection" dynamisch von SQL vorgenommen wird, sofern hier nicht manuell eingegriffen wurde. allerdings kann ein unzureichender arbeitsspeicher sich hier negativ auf den wert auswirken!

Wären bei mir die ersten Ansätze! Aber vermutlich hast Du das schon betrachtet?
Meine Reisen: 2011 Roundtrip Kalifornien
Geplante Reisen: 2013 Florida / Bahamas

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »qwertz0211« (21. April 2011, 08:32)


Werbung

unregistriert

Werbung


  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

12

Donnerstag, 21. April 2011, 08:40

Danke für den Input, aber:

Die Anzahl der Max User steht auf 25 und kann bei einem Shared Host
nicht verändert werden. Wir betreiben hier ja keinen eigenen Server.
Das Reicht auch im Normalfall, denn die Datenbank hat nix zu tun.
Aber irgendetwas flutet hier mit einer Aktion den SQL Server.
Da werden 25 Connections aufgemacht und nicht geschlossen.
Die bleiben dann 120 Sekunden offen und werden vom SQL Server beendet. Die Anfrage auf die Datenbank kommt von localhost....
Kann also alles sein

Das Problem ist nur: Wir haben nix am System verändert...
Alle Daten auf dem Server tragen ein Datum von 2006 bis 2009

Also muss es ein Beitrag sein oder soetwas was die Datenbank zerlegt.
Und bevor die Frage kommt: Ja, die Passwörter haben wir schon geändert.

Unser Hoster sagt nur, wir sollen auf einen eigenen Server umziehen.
Klar, dann wird es laufen, da ich da genug Reserven habe..
Aber das kostet 99€ im Monat zu 10€ aktuell

Aber wenn es hier draußen noch mehr IT Fachmänner gibt...
Ich bin für jede Anregung dankbar, denn ich finde so den Fehler nicht


Andree

(selber IT Admin :zwinker:)
»Andree« hat folgendes Bild angehängt:
  • fehler-sql.jpg

Beiträge: 345

Danksagungen: 74

  • Nachricht senden

13

Donnerstag, 21. April 2011, 08:51

hm...

wirklich schwierig! schon mal im log überprüft ob die sessions wirklich geschlossen werden oder irgendwie immer welche hängen bleiben?? es sei denn es gibt "automaten" die als user auf dem SQL angelegt sind, die sich bei entsprechenden aktionen selber anmelden. aber davon gehe ich jetzt nicht aus, oder?

schade das du die anzahl der connections nicht verändern kannst. wäre das einfachste gewesen. einfach dynamisch einstellen und gut ist :-)


grüße

chris

woher kommen denn die ganzen "localhost" zugriffe? alleine das ist ja schon irgendwie seltsam, oder? hast du prozesse laufen, die (wie oben schon angedacht) von selbst als user auf die datenbank zugreifen um sich selbst zu aktualisierern oder sowas?
Meine Reisen: 2011 Roundtrip Kalifornien
Geplante Reisen: 2013 Florida / Bahamas

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »qwertz0211« (21. April 2011, 08:56)


  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

14

Donnerstag, 21. April 2011, 08:54

Zitat

Original von qwertz0211
hm...

wirklich schwierig! schon mal im log überprüft ob die sessions wirklich geschlossen werden oder irgendwie immer welche hängen bleiben?? es sei denn es gibt "automaten" die als user auf dem SQL angelegt sind, die sich bei entsprechenden aktionen selber anmelden. aber davon gehe ich jetzt nicht aus, oder?

schade das du die anzahl der connections nicht verändern kannst. wäre das einfachste gewesen. einfach dynamisch einstellen und gut ist :-)



Das Problem wenn Du die max Connections erhöhst ist:

Dann nimmt sich dieser Task halt 100 Sessions und macht den Server dicht...

Automaten haben wir nicht, jedenfalls nicht das ich wüsste.
Ich habe den Kram ja nur von Kalle übernommen :zwinker:
Logfiles.... da muss ich mich mal mit beschäftigen. Da hier aber doch
recht viel los ist, sind die Logfiles nicht gerade klein :99:

Ich mache jetzt erst mal Osterurlaub, aber so wie ich mich kenne lässt
mir das über Ostern keine Ruhe...

Andree

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

15

Donnerstag, 21. April 2011, 08:58

Zitat

Original von VoF Fan
Ich hab nachweislich ja keine Ahnung von der Materie, aber was mir aufgefallen ist, manche User sind längst raus und Offline und werden noch extrem lange angezeigt. Stellenweise sogar 30 Minuten.

Ja, das ist ein Wunsch von Kalle....
Das beschäftigt die Datenbank aber nicht, das ist nur ein Verweis.
Auf die Datenbank wird nur bei einem Query (Abfrage) zugegriffen, oder
wenn du etwas schreibst. Das dauert meistens nicht mal eine Sekunde.

Der Wert das die User hier noch 30 Minuten zu sehen sind, steht auch auf
30 Minuten. Werde den gleich mal ändern, sicher ist sicher


Andree


Edith: Steht jetzt auf 5 Minuten

Werbung

unregistriert

Werbung


Beiträge: 345

Danksagungen: 74

  • Nachricht senden

16

Donnerstag, 21. April 2011, 09:23

RE: PROBLEME MIT DEM FORUM

ja, besser ist das!

nicht das da was im argen ist und der sql server das doch nicht auseinander halten kann! abwarten...

ansonsten: mach ich locker UUUURRRLLLAAAAAUUUUUBBBB :-)
Meine Reisen: 2011 Roundtrip Kalifornien
Geplante Reisen: 2013 Florida / Bahamas

andie

Moderator

Beiträge: 4 883

Danksagungen: 340

  • Nachricht senden

17

Freitag, 22. April 2011, 09:12

Ich hab auch das Gefühl, dass es besser geworden ist.
Seit gestern keine Fehlermeldung mehr und auch keine Fehler.

Frohe Ostern ...

btw:
Vermisse den aktuellen $-Kurs im Portal.
Wenn die Links nach und nach wieder eingebaut werden, dann bitte diesen zuerst. :zwinker:
Bei Stammtischtreffen dabei

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

18

Freitag, 22. April 2011, 11:02

Ostern ist absolut kein Gradmesser für die Fehler, ist ja wenig los.
Die Sachen im Portal bleiben auf jeden Fall bis Donnerstag ausgeblendet.
Auch der $ Ticker. Der kommt dann aber wieder als erstes rein.

Andree

  • »Andree« ist der Autor dieses Themas

Beiträge: 2 908

Beruf: Systemtechniker/IT und TK

Danksagungen: 363

  • Nachricht senden

19

Donnerstag, 28. April 2011, 15:54

So, ich habe das Portal wieder so aufgebaut wie
vor einer Woche. Mal sehen ob der Fehler, welcher in den
letzten Tagen nicht mehr auftrat, wiederkommt.

Wer etwas sieht, bitte hier posten!

Danke...
Andree

Werbung

unregistriert

Werbung


Beiträge: 2 085

Danksagungen: 165

  • Nachricht senden

20

Dienstag, 3. Mai 2011, 07:37

Gerade eben kurz nicht erreichbar

SQL-DATABASE ERROR

Database error in WoltLab Burning Board (): Link-ID == false, connect failed
mysql error: User d002809d already has more than 'max_user_connections' active connections
mysql error number: 1203
mysql version: unknown
php version: 5.2.12-nmm2
Date: 03.05.2011 @ 07:34
Script: /wbb2/thread.php?postid=319733
Referer: http://www.usa-stammtisch.de/wbb2/hmportal.php?sid=